Installing and Operating SU Podium V2

SU Podium V2 requires SketchUp 7, 8 or 2013. Windows version requires Windows XP, Vista or 7. Mac version will require OS-X 10.6.x or above. The V2 engine is multi-threaded meaning it will take advantage of all your CPU core's. You also need a reasonable amount of RAM to hold 3d scene data. The more RAM you have, the more complex models you can render. If you have a 64 bit operating system, Podium will take advantage of all your RAM. For Windows there are two versions, 32 bit and 64 bit. Mac version is not currently 64 bit but does not have the same memory limitations that Windows 32 versions have.

1. Install

Note: SketchUp 2014 users must use SU Podium V2 Plus and not V2

The install process is straight forward and in most cases will require no input from the user. The main thing to be aware of is which version of SketchUp you are using. When you purchase SU Podium V2 from Cadalog, Inc's web store or from your reseller, you will receive a web page link that has the SU Podium V2 versions to download. You will also receive a 16 digit license code. If you need to reinstall SU Podium V2 for some reason, go to the Free Trial page and download the free evaluation version and activate the trial version with your license code. Alternative, click on this link to go to the Version 2 web page and download from here.

    Note: Free Trial version users.You will not receive a license code. Instead, ignore the License Manager dialog box that comes up, requesting you to enter a license. In the License Manager dialog, you should see the amount of time left in your evaluation period. When you render something for the first time, let the Process Scene process end and the License Manager dialog box will go away.

Back to the Top

Install for SketchUp 7 or 8 Windows and Mac

SketchUp 8 customers should use SU Podium V2 Plus. It has more features and is a free upgrade.

    Windows Install for SketchUp 7 or 8.

    Make sure you quit SketchUp completely before running the SU Podium V2 install.
    You must have a Windows Administrator User Account to install SU Podium V2. You can run the program without being an administrator but to install it you must be have administrative privileges. Close SketchUp before starting the install. Double click on the install file you have downloaded. An installation program will start. The default install location for SU Podium V2 is \program files\google\google sketchup 8\plugins\. Change the number 8 to 7 if you are installing for SketchUp 7. If you have a 64 bit Windows operating system, the default location will be \program files (x86)\google\google sketchup 8 (or 7)\plugins\. The installation will create a sub-folder in the \google sketchup 8 (or 7)\plugins\ folder called SU_Podium_V2. There will also be a ruby load file in the plugins folder called SU_Podium_V2.rbs. In addition, SU_Podium_Browser.rbs file is installed. If you need to uninstall SU Podium V2, use the Uninstall option from the All Programs ---->SU Podium V2 location.
    Windows 64 bit version There is a SU Podium Version 2, Windows 64 bit version. When you purchase SU Podium V2 you will be sent a license code and a URL to download Windows, Windows 64 and Mac versions of SU Podium V2. 32 bit version will work on any Windows 32 bit or 64 bit computer. However, the 64 bit version supports more RAM memory. Therefore, it will rendering much larger SketchUp files. If you have more than 4 gigabytes of RAM, you should consider downloading and installing the Windows 64-bit version.
    Windows Uninstall If you need to uninstall SU Podium V2, use the Uninstall option from the All Programs ---->SU Podium V2 location. However, you can also remove all the folders and files manually. The installation will create a sub-folder in the c:\program files (x86) \google\ goggle sketchup 8 (or 7)\plugins\ folder called SU_Podium_V2. There will also be a ruby load file in the plugins folder called SU_Podium_V2.rbs. In addition, SU_Podium_Browser.rbs file is installed. Manually deleting these folders and files will effectively uninstall SU Podium V2.
Back to the Top

    Mac install for SketchUp 7 or 8

SketchUp 8 customers should use SU Podium V2 Plus. It has more features and is a free upgrade.

    Make sure you quit SketchUp completely before running the SU Podium V2 install.
    Mac Install for SketchUp 7. Close SketchUp before starting the install program. Double click on the SU_Podium_V2_SU7_Mac.zip file that you downloaded. This will unzip the install file. Double click on the install, package file. SU Podium V2 is installed in the Macintosh HD\Library\Application Support\Google SketchUp 7\SketchUp\Plugins\. A new folder in the Plugins directory called SU_Podium_V2 is created as well as ruby load files called SU_Podium_V2.rbs and SU_Podium_Browser.rbs. If you need to uninstall SU Podium V2, move the SU_Podium_V2.rbs, SU_Podium_Browser.rbs and SU_Podium_V2 folder into the trash bin.
    Mac Install for SketchUp 8. Make sure you purchase or upgrade the SU Podium V2 for SketchUp 8. This only works on SketchUp 8. Close SketchUp before starting the install program. Double click on the SU_Podium_V2_SU8_Mac.zip file that you downloaded. This will unzip the install file. Double click on the install, package file. SU Podium V2 is installed in the Macintosh HD\Library\Application Support\Google SketchUp 8\SketchUp\Plugins\. A new folder in the Plugins directory called SU_Podium_V2 is created as well as ruby load files called SU_Podium_V2.rbs and SU_Podium_Browser.rbs.

    Mac Uninstall.

    Please click here to find out how to remove SU Podium V2 or V2 Plus Beta very easily.

Back to the Top

SketchUp 2013 Install

    Windows Install for SketchUp 2013

    Make sure you quit SketchUp completely before running the SU Podium V2 install.

    New users or new install

    SketchUp 2013 plugin location is different from SketchUp 7 and 8. With SketchUp 2013, SU Podium V2 should be installed in this folder: c:\program files (x86)\sketchup\ sketchup 2013\plugins\ if your Windows is a 64 bit version.

    (If your Windows is a 32 bit version the install location should be c:\program files\sketchup\ sketchup 2013\plugins\.)
    If this a new computer or this your first time installing SU Podium V2, use the SU Podium V2 for SketchUp 2013 install file. This has a default Destination Location as \program files (x86)\sketchup\sketchup 2013\plugins\.

    Existing SU Podium V2 users who are switching to SketchUp 2013

    You will fist need to download and re-install SU Podium V2 for SketchUp 2013. Please go to the Version2 page to download.

    Make sure you have your SU Podium V2 license code before you install because you will need it.

    Make sure you download the correct install file for SketchUp 2013 Windows. After downloading, make sure SketchUp 2013 is closed.

    There is a likelihood that the SU Podium V2 for SketchUp 2013 install program, will have an incorrect default Destination Location that is pointing to Google SketchUp 8. You will need to manually change this. Because of this, please go through the installation process carefully.
      If the destination folder path looks like the above image and points to Google SketchUp 8, you will need to change it.
      (This is due to the way the install program works. If the previous version of SU Podium V2 is not uninstalled, the destination location is saved in the Windows Registry.)

      If this is case, use the Browse button to change the Destination Location.

      Then from your Program Files (x86) folder, choose SketchUp\SketchUp 2013. Do not choose the Plugins folder.

      Your Destination Location should look like this below:

    SU Podium V2 will be installed in c:\program files (x86)\sketchup\sketchup 2013\plugins\ . A folder called SU_Podium_V2 will be installed there. There will also be a ruby load file in the plugins folder called SU_Podium_V2.rbs. In addition, SU_Podium_Browser.rbs file is installed. If you need to uninstall SU Podium V2, use the Uninstall option from the All Programs ---->SU Podium V2 location.
    You will need to activate the SU Podium license again after re-installing for SketchUp 2013.

    Windows Uninstall for SketchUp 2013

    If you need to uninstall SU Podium V2, use the Uninstall option from the All Programs ---->SU Podium V2 location. Or go to the Control Panel, Programs and Features and find SU Podium V2.xx on the list of programs and uninstall.

    The installation will create a sub-folder in the c:\program files (x86) \sketchup\sketchup 2013\plugins\ folder called SU_Podium_V2. There will also be a ruby load file in the plugins folder called SU_Podium_V2.rbs. In addition, SU_Podium_Browser.rbs file is installed. Manually deleting these folders and files will effectively uninstall SU Podium V2. However, note, any new presets you created in the SU Podium V2/Preset folder will be deleted as well.

Back to the Top

    Mac Install for SketchUp 2013

Mac SketchUp customers should use SU Podium V2 Plus. It has more features and is a free upgrade.

    New Users
    Make sure you quit SketchUp completely before running the SU Podium V2 install.
    When you purchase or update SU Podium V2 for SketchUp Mac, you will be directed to a download page from an email receipt.

    Existing SU Podium V2 users who are switching to SketchUp 2013
    You will fist need to download and re-install SU Podium V2 for SketchUp 2013. Please go to the Version2 page to download. After downloading, install SU Podium V2 for SketchUp 2013. Make sure you download the correct install file.

    Make sure you download the SketchUp 2013 version. This install file only works on SketchUp 2013. Close SketchUp before starting the install program. Double click on the SU_PodiumV2_SU2013_11_1500.pkg.zip file that you downloaded. This will unzip the install file. Double click on the install, package file. SU Podium V2 is installed in the:
    Macintosh HD\Library\Library\Application Support\SketchUp 2013\SketchUp\Plugins\

      Please Note: SU Podium V2 for now is being instsalled in the MacInstosh HD global directory which is here: Macintosh HD\Library\Library\Application Support\SketchUp 2013\SketchUp\Plugins\.
      Most plugins for SketchUp 2013 get installed in the standard SketchUp 2013 plugins folder which is here in the User directory:
      Username\Library\Application Support\ SketchUp 2013\SketchUp\Plugins\

    Mac Uninstall. Please click here to find out how to Remove SU Podium V2.
    Mac Install Failed! In rare cases the SU Podium V2 Mac install.app will fail to install and you might see a message like this:

Trouble shooting your install Windows and Mac install.

    Mac Trouble shoot

Trouble Shoot Mac install

In some cases, the Mac package installer, forces you to select Install for Me. This can create problems described below. Use the Install for all user of this computer option. You may have click Go Back but eventually the Install for all user will become available.

How to uninstall SU Podium V2 or V2 Plus

Back to the Top

2. Activate your License if you purchased SU Podium. (Trial users, ignore this step.)

    Activate your sixteen alpha numeric license code. If you are using the commercial version of SU Podium, you will need to activate your 16 character license code to get the full version working. You can register the license in two ways. First, you can pick License from the SU Podium V2 pull down menu and activate your license. Second, when you click render, you will be prompted to activate your license.

    (If you are using the evaluation version, ignore this dialog box and wait for the process scene to finish to continue to evaluate.)

    Once the license is registered, quit and restart SketchUp. This action will turn off the trial mode of SU Podium V2.
    Trouble shooting your install. One common problem reported is that after you install SU Podium V2, the Podium pull-down and tool bar does not show up in SketchUp. Make sure you restart SketchUp, if SketchUp was open during the install. There's typically one reason why SU Podium V2 menus do not appear in SketchUp and that is to do with the installation. Please click here to read about how to solve this issue.
Back to the Top

3. Render process and getting started

    After installing SU Podium V2 for SketchUp, you can access SU Podium V2 from the SketchUp plug-ins pull down menu or from the SU Podium V2 tool bar.

    If for some reason, you do not see the SketchUp Plugins menu in SketchUp, please read here.

    Before you render your first SketchUp model, get familiar with the Options dialog box and the various settings that are controlled there. We also recommend that render a sample model from here SU Podium V2 models page as a way to test Podium.

    To introduce yourself to V2's rendering process, download one of the sample models.

    Open the model in SketchUp.

    First click on the Options menu from the pull down or the tool bar. In the preset pull down list, pick Default.pps. This preset is not the best but the easiest to start with. In the Output tab, under Dimensions, pick a Fixed size or the default Viewport size for the rendered image size. Click the OK button. Then pick the Render menu from the pull-down or tool bar. A series of sequences will happen after clicking on the Render icon or menu. If this is you first render, you will be prompted to Activate your license.

  • Processing Scene - this first step is where SketchUp geometry and textures are converted to Podium's mesh modeler. If your SketchUp model is very big, this process can take several minutes. Please read here if you find that Processing Scenes is taking a very long time.
  • UV Mapping - is the 2nd step. This step is often so fast you will not see it.
  • Prerendering in progress. After UV Mapping, you will see an OOPR message that says Prerendering is in progress and a percentage of completion.
  • Raytracing. Podium V2's raytracing is a high quality raytracing program and is one of the fastest on the market. This will occur after Prerendering. From this point you can Preview the rendering.
  • Resampling Edges. This is the final step and often takes longer than Raytracing. Most of resampling is the anti-aliasing process which smooths out the edges of the rendered image. The preset you choose from the Options menu controls the level of anti-aliasing.

    Once Raytracing starts, highlight the item line in OOPR and select Show menu in OOPR to view the render progress dynamically. The Show image will be smaller than the final rendered image. As a default, the final rendered image will be saved to the folder that the SketchUp model is saved in unless you change the location for saved images to be saved in. Please read about Save in the Options section.

Back to the Top

4. Download and test some ready made SketchUp models.

    Click on this link to go to the SU Podium V2 models page. You can do download several render ready SketchUp models to test results.

5. Where to get Support

    The following Help pages will guide you through Installation and using and applying SU Podium. Please take a moment and read through the Installation chapter if you are having difficulty with the install. If you are having trouble finding your serial number, please take a look at the FAQ section of this web site. There is a detailed description of how to find your serial number. In addition, you can get support from the following areas:

  • The SU Podium Forum - an active Forum with two or three experts online almost any time.
  • E-mail support - support@cadalog-inc.com Please e-mail us with any question, any time. You should get a reply within 24 hours. Usually, much faster. If you are experiencing crashes please look at this check list to help us understand the issue.
  • Upload your models. If you are having problems rendering your models, feel free to upload your .skp file to Cadalog's box.com account.
  • Due to number of potential malware issues, after uploading, please send an e-mail separately to Cadalog, Inc. to let us know you have uploaded a .skp file and why. Please do not upload anything but .skp files. If we do not receive an email about your uploaded model, the file will eventually be deleted due to security precautions. Anything other than .skp will also be deleted.

  • FAQ section
Back to the Top

6. What version am I running?

    Select the About menu item in the SU Podium V2 pull down menu. This will link to a web page which will display the version number.

7. Support Check list

    Please look at this check list of items that will help in supporting your SU Podium installation.